Note : These games require Adobe Flash Player or Adobe Shockwave Player. If game does not load, try installing the newest plugin here (click on the icon) :

Download Flash

or

Download Shockwave